Hello, thanks for the advert, the challenge begins!

Evening folks,

Firstly thank you for letting me in! I've recently purchased our first A2 - a Y plate 1.4 Petrol in what I believe to be Azure blue. Full History up to 2018, then very little to nothing. It's got keep-fit rear windows, concert stereo and climate.

It's come to us with a few issues, which I'm trying to establish route cause for, including:

  • Petrol flap button u/s - no lights on the buttons when the door is opened.
  • Drivers window will go down, but not up. Sometimes a battery reset will solve, other times not. Passenger window has a mind of it's own, will open and close, but halfway through closing, sometimes will go down, up and then down again.
  • Service hatch doesn't close flush.
  • Passenger side rear wheel bearing v grumbly
  • Engine Management Light on when purchased, has now cleared!
Upshots:
  • the a/c works which is glorious!
  • Despite the very loud wheel bearing, it drove back from Essex nicely!
  • Two keys and radio code (dead pixels on display.
As there's no history of a service, I've bought a set of Mann filters and some Castrol Edge 5w30. It's had a cambelt and water pump in 2017 at 25,000 miles ago, so believe due on time!

Be keen to know if there are any recommended upgrades or critical check points on these cars. I come from a background of British motors, so used to a few niggles!

Looking forward to being involved with the group!

fullsizeoutput_b84.jpeg


Cheers,

Jake
 

steve_c

Member
Welcome to the club, Jake.

If you haven't already done so, it's worth upgrading your membership, which will give you access to the market:
 

CrispyEdd

Member
Welcome! Try looking for threads by searching google and adding 'A2OC' on the end. THe conveince control unit is the likely a lot of your issues. I spoke to this seller before buying one closer to home, seems like its in good condition and was well priced, great purchase! Have fun and welcome!
 
Thanks all, I've upgraded my account :)

Re the window, I've tried some silicone down the runners. I've noticed now that the window glass drops to a level, but not all the way down. Does that hint towards one part in particular? When using the switch you can hear a relay/motor click in the door, so there's power.
 

A2Steve

Member
Sounds like the window motor has lost the parameters of what’s up and what’s down. Close the widow and hold it the button up for 10 seconds. Then try dropping it all
The way down and do the same at the bottom if it will go.

There’s nothing complicated about the setup in the door, and I have all of the parts if needed.
 
Sounds like the window motor has lost the parameters of what’s up and what’s down. Close the widow and hold it the button up for 10 seconds. Then try dropping it all
The way down and do the same at the bottom if it will go.

There’s nothing complicated about the setup in the door, and I have all of the parts if needed.
Thanks Steve,

After leaving the battery off for a couple of hours, I tried the switch - it wouldn't let me put the window back up, but it would drop. The glass will now slide up and down the runners, but upon moving the switch, nothing.

Also, the fuel filler flap button worked once, but now dead again. I've given it a good dowsing of servisol to see if that helps.
 
So the window glass now slides free in the runners, doing the switch does nothing the majority of the time, when there is movement, there's a rather tragic sounding crunching sound. Does that suggest regulator?

The servisol on the switch didn't improve. After the battery reset, both pillar switches flashed three times before dying.

Hoping tomorrow's job to change the wheel bearing addresses one issue! :-D
 
Sorry for the lack of updates.

The new window regulator kindly provided by Steve has sorted the u/s window.

This just leaves the b pillar switches not working, a passenger side rear window that goes up and down however it likes when pressing the switch and the central locking double cycling when operating the plip.

Since my last post we picked up an 02 sport in red which although needs a service and belt kit. Everything does electrically work at least!
 

dj_efk

A2OC Donor
Welcome! Try looking for threads by searching google and adding 'A2OC' on the end. THe conveince control unit is the likely a lot of your issues. I spoke to this seller before buying one closer to home, seems like its in good condition and was well priced, great purchase! Have fun and welcome!
I have to say from the sounds of it @CrispyEdd could be on the money with your remaining issues, however paging our A2 electric guru @timmus to the red phone for a more informed opinion.
 

Proghound

Admin Team
I'm with @oneflewover. My money's on the microswitches in the locks of at least the driver's door (hence the b-pillar buttons not responding), but possibly others as well.
 
Top